PostgreSQL psqlODBC Treiber: Schwachstelle ermöglicht Denial of Service
WID-SEC-2026-4038 · first 20.10.2026 · updated 28.10.2026 · CVSS 5,9
What it is about
PostgreSQL ist eine frei verfügbare Datenbank für unterschiedliche Betriebssysteme. Ein entfernter, anonymer Angreifer kann eine Schwachstelle in PostgreSQL ausnutzen, um einen Denial of Service Angriff durchzuführen.
Under what conditions?
Over the network and without logging in. This is the most dangerous combination: attackers can scan reachable devices automatically.
What can happen in the worst case
An attacker could use the vulnerability to
- einen Denial of Service Angriff durchzuführen
Am I affected?
Affected according to the BSI:
- SUSE openSUSE
- Open Source PostgreSQL <18.00.0005
- Open Source PostgreSQL >=08.01.0102
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source PostgreSQL 18.00.0005
- Open Source PostgreSQL >=08.01.0102
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- PostgreSQL 19 RC 1 ReleaseNotes vom 2026-10-19 www.postgresql.org
- NIST Vulnerability Database vom 2026-10-19 nvd.nist.gov
- GitHub advisory vom 2026-10-12 github.com
- openSUSE Security Update OPENSUSE-SU-2026:12135-1 vom 2026-10-27 lists.opensuse.org
CVE: CVE-2026-109448
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.