vllm: Mehrere Schwachstellen
WID-SEC-2026-4051 · first 20.10.2026 · updated 27.10.2026 · CVSS 8,1
What it is about
Open Source vLLM ist eine Open-Source-Bibliothek für schnelle und effiziente Inferenz von Large Language Models (LLMs). Ein Angreifer kann mehrere Schwachstellen in vllm ausnutzen, um beliebigen Programmcode auszuführen, um einen Denial of Service Angriff durchzuführen, um Informationen offenzulegen und um Sicherheitsvorkehrungen zu umgehen.
Under what conditions?
The BSI does not name any particular preconditions. Exploitable remotely according to the BSI.
What can happen in the worst case
An attacker could use the vulnerability to
- beliebigen Programmcode auszuführen
- einen Denial of Service Angriff durchzuführen
- Informationen offenzulegen
- Sicherheitsvorkehrungen zu umgehen
Am I affected?
Affected according to the BSI:
- Open Source vllm <0.32.0
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source vllm 0.32.0
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- GitHub Security Advisory GHSA-542m-9234-8gvf vom 2026-10-19 github.com
- GitHub Security Advisory GHSA-6757-hggm-hp2w vom 2026-10-19 github.com
- GitHub Security Advisory GHSA-8397-8qf6-f2gm vom 2026-10-19 github.com
- GitHub Security Advisory GHSA-frvg-qw88-hww9 vom 2026-10-19 github.com
- GitHub Security Advisory GHSA-gq5q-89c7-vhvx vom 2026-10-19 github.com
- GitHub Security Advisory GHSA-h3rc-j82p-2c3h vom 2026-10-19 github.com
- GitHub Security Advisory GHSA-q97c-p368-75c4 vom 2026-10-19 github.com
- GitHub Security Advisory GHSA-vvpg-rrww-wpmh vom 2026-10-19 github.com
- GitHub Security Advisory GHSA-x567-49g5-p4cf vom 2026-10-19 github.com
CVE: CVE-2025-61620, CVE-2025-62426, CVE-2026-115911, CVE-2026-115912, CVE-2026-115913, CVE-2026-115914, CVE-2026-115916, CVE-2026-115917, CVE-2026-115918
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.