vllm: Mehrere Schwachstellen ermöglichen Denial of Service
WID-SEC-2026-4151 · first 26.10.2026 · updated 26.10.2026 · CVSS 6,5
What it is about
Open Source vLLM ist eine Open-Source-Bibliothek für schnelle und effiziente Inferenz von Large Language Models (LLMs). Ein Angreifer kann mehrere Schwachstellen in vllm ausnutzen, um einen Denial of Service Angriff durchzuführen.
Under what conditions?
The BSI does not name any particular preconditions. Exploitable remotely according to the BSI.
What can happen in the worst case
An attacker could use the vulnerability to
- einen Denial of Service Angriff durchzuführen
Am I affected?
Affected according to the BSI:
- Open Source vllm <0.24.0
- Open Source vllm <0.29.0
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source vllm 0.24.0
- Open Source vllm 0.29.0
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- Red Hat Bugtracker 2560391 vom 2026-10-25 bugzilla.redhat.com
- Red Hat Bugtracker 2560405 vom 2026-10-25 bugzilla.redhat.com
- Red Hat Bugtracker 2560417 vom 2026-10-25 bugzilla.redhat.com
CVE: CVE-2026-116174, CVE-2026-116175, CVE-2026-116181
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.