Threat landscape
medium

Composer: Mehrere Schwachstellen

WID-SEC-2026-4254 · first 30.10.2026 · updated 30.10.2026 · CVSS 7,1

×

What it is about

Composer ist ein Open-Source-Abhängigkeitsmanager für PHP-Projekte. Ein entfernter, anonymer Angreifer kann mehrere Schwachstellen in Composer ausnutzen, Sicherheitsvorkehrungen zu umgehen, Dateien zu manipulieren oder Informationen auszulesen.

Under what conditions?

Over the network and without logging in. This is the most dangerous combination: attackers can scan reachable devices automatically.

Am I affected?

Affected according to the BSI:

  • Open Source Composer <2.11.0
  • Open Source Composer <2.2.31

The installed version is usually shown under “Help → About” or in the device’s admin interface.

What helps?

Update to at least:

  • Open Source Composer 2.11.0
  • Open Source Composer 2.2.31

Is the vulnerability already being exploited?

None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.

Information and sources

Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.

Set up in an hour, trained in a week.

Create a free account, add your team, unlock the course. You only pay when you start. Would you rather see what a test email looks like first? The self-test is free.

Add your team Test it yourself first