Threat landscape
high

Python: Schwachstelle ermöglicht Manipulation

WID-SEC-2023-1280 · first 13.03.2019 · updated 19.10.2026 · CVSS 8,1

×

What it is about

Python ist eine universelle, üblicherweise interpretierte höhere Programmiersprache. Ein Angreifer kann eine Schwachstelle in Python ausnutzen, um HTTP Anfragen zu manipulieren.

Under what conditions?

The BSI does not name any particular preconditions. Exploitable remotely according to the BSI.

What can happen in the worst case

An attacker could use the vulnerability to

  • HTTP Anfragen zu manipulieren

Am I affected?

Affected according to the BSI:

  • Open Source Python 2.7
  • Debian Linux
  • Red Hat Enterprise Linux
  • Ubuntu Linux
  • SUSE Linux
  • Oracle Linux
  • Open Source Python 3.7
  • Open Source Python 3.8
  • Avaya Aura Communication Manager
  • Avaya Aura Session Manager
  • IBM QRadar SIEM 7.5
  • F5 BIG-IP <17.5.1

and 1 more

The installed version is usually shown under “Help → About” or in the device’s admin interface.

What helps?

Update to at least:

  • F5 BIG-IP 17.5.1

Is the vulnerability already being exploited?

None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.

Information and sources

and 6 more sources in the original advisory

CVE: CVE-2019-9740

Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.

Set up in an hour, trained in a week.

Create a free account, add your team, unlock the course. You only pay when you start. Would you rather see what a test email looks like first? The self-test is free.

Add your team Test it yourself first