GNU Emacs und Red Hat Enterprise Linux: Schwachstelle ermöglicht Codeausführung
WID-SEC-2024-3558 · first 28.11.2024 · updated 19.10.2026 · CVSS 7,5
What it is about
GNU Emacs ist Texteditor, welcher durch eine Programmierschnittstelle in der Programmiersprache Emacs Lisp mit beliebigen Erweiterungen ausgestattet werden kann. Red Hat Enterprise Linux (RHEL) ist eine populäre Linux-Distribution. Ein entfernter, anonymer Angreifer kann eine Schwachstelle in GNU Emacs und Red Hat Enterprise Linux ausnutzen, um beliebigen Programmcode auszuführen.
Under what conditions?
Over the network and without logging in. This is the most dangerous combination: attackers can scan reachable devices automatically.
What can happen in the worst case
An attacker could use the vulnerability to
- beliebigen Programmcode auszuführen
Am I affected?
Affected according to the BSI:
- Debian Linux
- Amazon Linux 2
- Red Hat Enterprise Linux
- Ubuntu Linux
- SUSE Linux
- Oracle Linux
- Gentoo Linux
- SUSE openSUSE
- RESF Rocky Linux
- Open Source GNU Emacs <30.0.92
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
and 1 more
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source GNU Emacs 30.0.92
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- SUSE Security Update SUSE-SU-2024:4392-1 vom 2024-12-20 lists.opensuse.org
- SUSE Security Update SUSE-SU-2024:4392-1 vom 2024-12-20 lists.opensuse.org
- openSUSE Security Update OPENSUSE-SU-2024:14591-1 vom 2024-12-18 lists.opensuse.org
- Red Hat Bugzilla vom 2024-11-27 bugzilla.redhat.com
- GitHub Advisory Database vom 2024-11-27 github.com
- Amazon Linux Security Advisory ALAS-2025-2757 vom 2025-02-25 alas.aws.amazon.com
- Debian Security Advisory DLA-4069 vom 2025-02-27 lists.debian.org
- Debian Security Advisory DSA-5871 vom 2025-02-28 lists.debian.org
- SUSE Security Update SUSE-SU-2025:0798-1 vom 2025-03-06 lists.opensuse.org
- Red Hat Security Advisory RHSA-2025:9448 vom 2025-06-24 access.redhat.com
- Oracle Linux Security Advisory ELSA-2025-9448 vom 2025-06-24 linux.oracle.com
- Red Hat Security Advisory RHSA-2025:4787 vom 2025-05-12 access.redhat.com
- Red Hat Security Advisory RHSA-2025:4794 vom 2025-05-12 access.redhat.com
- Red Hat Security Advisory RHSA-2025:4793 vom 2025-05-12 access.redhat.com
- Oracle Linux Security Advisory ELSA-2025-4787 vom 2025-05-12 linux.oracle.com
- Gentoo Linux Security Advisory GLSA-202506-01 vom 2025-06-12 security.gentoo.org
- Red Hat Security Advisory RHSA-2025:11030 vom 2025-07-15 access.redhat.com
- Oracle Linux Security Advisory ELSA-2025-11030 vom 2025-07-16 linux.oracle.com
- Rocky Linux Security Advisory RLSA-2025:4787 vom 2025-07-29 errata.build.resf.org
- Red Hat Security Advisory RHSA-2025:13276 vom 2025-08-07 access.redhat.com
- Ubuntu Security Notice USN-8011-1 vom 2026-02-04 ubuntu.com
- Red Hat Security Advisory RHSA-2026:84591 vom 2026-10-19 access.redhat.com
CVE: CVE-2024-53920
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.