Threat landscape
medium

vim: Mehrere Schwachstellen

WID-SEC-2026-2522 · first 27.07.2026 · updated 14.10.2026 · CVSS 7,0

×

What it is about

Vim (Vi IMproved) ist eine Weiterentwicklung des Texteditors vi. Ein lokaler Angreifer kann mehrere Schwachstellen in vim ausnutzen, um beliebigen Programmcode mit Benutzerrechten auszuführen, einen Denial-of-Service-Zustand auszulösen oder vertrauliche Informationen offenzulegen.

Under what conditions?

Only with access to the device or an account on it. Often the second step after a phishing email.

What can happen in the worst case

An attacker could use the vulnerability to

  • beliebigen Programmcode mit Benutzerrechten auszuführen
  • einen Denial-of-Service-Zustand auszulösen oder vertrauliche Informationen offenzulegen

Am I affected?

Affected according to the BSI:

  • Amazon Linux 2
  • Red Hat Enterprise Linux
  • IBM QRadar SIEM
  • RESF Rocky Linux
  • SUSE Linux
  • SUSE openSUSE
  • Oracle Linux
  • Open Source vim <9.2.0844
  • Open Source vim <9.2.0846
  • Open Source vim <9.2.0847

The installed version is usually shown under “Help → About” or in the device’s admin interface.

What helps?

Update to at least:

  • Open Source vim 9.2.0844
  • Open Source vim 9.2.0846
  • Open Source vim 9.2.0847

Is the vulnerability already being exploited?

None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.

Information and sources

and 20 more sources in the original advisory

CVE: CVE-2026-73076, CVE-2026-73072, CVE-2026-73071

Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.

Set up in an hour, trained in a week.

Create a free account, add your team, unlock the course. You only pay when you start. Would you rather see what a test email looks like first? The self-test is free.

Add your team Test it yourself first