OpenVPN: Mehrere Schwachstellen
WID-SEC-2026-3915 · first 14.10.2026 · updated 23.10.2026 · CVSS 7,1
What it is about
OpenVPN ist eine Open Source Software zum Aufbau eines Virtuellen Privaten Netzwerkes (VPN) über eine verschlüsselte TLS-Verbindung. Zur Verschlüsselung werden die Bibliotheken des Programmes OpenSSL benutzt. Ein entfernter, authentisierter Angreifer kann mehrere Schwachstellen in OpenVPN ausnutzen, um Sicherheitsmaßnahmen zu umgehen, Denial of Service Attacken durchzuführen und Informationen offenzulegen.
Under what conditions?
Over the network, but only with valid access (login required), for example with stolen credentials or as an insider.
What can happen in the worst case
An attacker could use the vulnerability to
- Sicherheitsmaßnahmen zu umgehen
- Denial of Service Attacken durchzuführen
- Informationen offenzulegen
Am I affected?
Affected according to the BSI:
- Open Source OpenVPN >=2.3.0
- Ubuntu Linux
- Open Source OpenVPN <2.7.8
- Open Source OpenVPN >=2.7_alpha3
The installed version is usually shown under “Help → About” or in the device’s admin interface.
What helps?
Update to at least:
- Open Source OpenVPN >=2.3.0
- Open Source OpenVPN 2.7.8
- Open Source OpenVPN >=2.7_alpha3
Is the vulnerability already being exploited?
None of the CVEs is in the CISA catalogue of exploited vulnerabilities. That does not mean there are no attacks, only that none are documented.
Information and sources
- Original BSI advisory (WID)
- OpenVPN Security Announcement vom 2026-10-13 community.openvpn.net
- OpenVPN Security Announcement vom 2026-10-13 community.openvpn.net
- CVE Record vom 2026-10-13 www.cve.org
- CVE Record vom 2026-10-13 www.cve.org
- Ubuntu Security Notice USN-8953-1 vom 2026-10-22 ubuntu.com
CVE: CVE-2026-84790, CVE-2026-88964
Source: BSI warning and information service (CERT-Bund); CISA. The assessment of the conditions is my reading of the BSI text; the external pages are in their original language.